My notes from studying for ICND2 640-816

classless (CIDR) allows vlsm
   
                               
point-to-point  (dedicated connection)    quality/limited flexibility
circuit switched  (phone call)    efficient/low speed     cost/low speed
packet switched  (shared networks, Frame Relay)    cost/more complex    efficient/more complex
http://www.iphelp.ru/faq/32/LiB0057.html

-the number of point-to-point links in a transmission path —–(hop)
-the data capacity of a link —(bandwidth)
-the amount of activity on a network resource —(load)
-usually refer to the bit error rate of each network link —(reliability)
-a configurable value based by default on the bandwidth of the interface —–(cost)
-the amount of time required to move a packet from source to destination —–(delay)
NB: the appropriate target as perceived by me is placed in the bracket. hope 9tut will get a graphical interpretation of this drag-and-drop soonest.

Loopback address    ::1
Link-local address    FE80::/10
Site-local address    FEC0::/10
Global address        2000::/3
Multicast address    FF00::/8

Below is a summary of IPv6 transition technologies:

  • 6 to 4 tunneling: This mechanism allows IPv6 sites to communicate with each other over the IPv4 network without explicit tunnel setup. The main advantage of this technology is that it requires no end-node reconfiguration and minimal router configuration but it is not intended as a permanent solution.
  • ISATAP tunneling (Intra-Site Automatic Tunnel Addressing Protocol): is a mechanism for transmitting IPv6 packets over IPv4 network. The word “automatic” means that once an ISATAP server/router has been set up, only the clients must be configured to connect to it.
  • Teredo tunneling: This mechanism tunnels IPv6 datagrams within IPv4 UDP datagrams, allowing private IPv4 address and IPv4 NAT traversal to be used.



Static route
ip route [where to (final destination)] [next hop]


NAT - done from config mode

ip nat pool MYPOOL 198.18.32.65 198.18.32.70 netmask 255.255.255.248
access-list 1 permit 192.168.6.64 0.0.0.63
ip nat inside source list 1 pool MYPOOL overload
int fa0/0
ip nat inside
exit
int fa0/1
ip nat outside

ACCESS LISTS ACL - done from config mode
destination source
Standard - Put as close to destination as possible
access-list 1 deny host 192.168.4.5
access-list 1 deny 192.168.4.5 0.0.0.0
int fa0/0
ip access-group 1 out
Extended - Put as close to source as possible, access-list source IP destination IP
access-list 100 deny tcp host 192.168.1.10 host 192.168.3.10 eq 80
int fa0/0
ip access-group 100 in
access-list 100 permit ip any any
IMPLICIT DENY at end of all these

STP - Spanning Tree 802.1d, RSTP (802.1w), Uses lowest priority or if tie then lowest MAC to find Root

show spanning-tree

VTP (Trunk with IEEE 802.1, 802.1q or ISL)
show vtp status
int fa0/1
(config-if)# switchport trunk encapsulation dot1q
(config-if)# switchport mode trunk
configure terminal
vtp domain ICND
vtp mode client
show mac-address-table
show interface trunk
show cdp neighbors
show cdp neighbors detail
show spanning-tree vlan 1
show vlan
show vlan brief
show vtp status

OSPF - cost as metric, hello multicast ip address 224.0.0.5, SPF/Dijkstra
, 110
Chooses highest loopback, interface, or manually set as router ID
Highest is DR
show ip ospf neighbors

EIGRP - bandwidth and as metric, hello multicast ip address 224.0.0.10, DUAL, FD/AD
, 90
for EIGRP variance means unequal cost paths
show ip eigrp neighbors
show ip eigrp topology (understand how to interpret this)
router eigrp 212
network 192.168.60.0
no auto-summary
end

test with pings
copy running-config startup-config
eigrp


poison reverse - a router learns from its neighbor that route is down, and the router sends update back to the neighbor with an infinite metric
LSA - packets flooded when a topology change occurs, causing network routers to update their topological database and recalculate routes
split horizon - prevents sending information back out the same interface that originally learned about the route
holddown timer - for a given period of time this causes the router to ignore any updates with poorer metrics to a lost network
defining a maximum, triggered updates etc drag/drop
ospf load balancing - bandwidth and ip ospf cost

show frame-relay map

show frame-relay pvc

cisco encapsulation is default, ietf for non-cisco equipment
pvc status=inactive : The PVC is configured correctly on the local switch but there is a problem on the remote end of the PVC